Front page Forums Technical Duckiebot Setup (connections, etc.) Duckiebot does not move

This topic contains 3 replies, has 2 voices, and was last updated by  hehonglu123 3 days, 8 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41241

    dreherd
    Participant

    Hi

    I assembled a Duckiebot and went through the tutorials on the “getting started” page. Everything worked fine until the step “Making your Duckiebot move” but now I’m stuck.
    The gui opens but nothing happens when buttons are pressed. Is there any way to check what’s causing this problem? I even checked the motor connections on the bot. Everything seems to be okay. Could this be a hardware problem?

    Some more information that could be helpful:
    1. I use Ubuntu 16 as OS
    2. Pinging the duckiebot via “duckiebot.local” is successful
    3. The necessary Docker containers mentioned in the documentation are running (demo_joystick and interface)
    4. The Duckiebot seems to receive my Key presses. When I press i (the toggle instagram thingy) there are new entries in the log of the demo_joystick container: (anti instagram message)
    5. I even tried the way that’s described in the DT18 documentation, but the Duckiebot just doesn’t want to move.
    6. The camera streaming and calibration worked

    #41242

    dreherd
    Participant

    Just tried with a gamepad… The pressed buttons are recognized. The Duckiebot does not move though. 🙁

    #41244

    dreherd
    Participant

    Solved by replacing the HAT.

    #42184

    hehonglu123
    Participant

    Hi dreherd,

    I’m having the same problem. Do you use a Duckiebot hut or Adafruit HAT. And how did you identify the defective HAT?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Close Menu