Package missing when running simulators agent

This topic contains 2 replies, has 2 voices, and was last updated by 3 years, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #28815


    I have the following stacktrace

    sam@ubuntu-MacBookPro:~/Project/duckietown/gym-duckietown-agent$ python3
    Traceback (most recent call last):
    File “”, line 37, in <module>
    env = gym.make(“Duckietown-Lf-Lfv-Navv-Silent-v0”)
    File “/home/sam/.local/lib/python3.5/site-packages/gym/envs/”, line 167, in make
    return registry.make(id)
    File “/home/sam/.local/lib/python3.5/site-packages/gym/envs/”, line 119, in make
    env = spec.make()
    File “/home/sam/.local/lib/python3.5/site-packages/gym/envs/”, line 85, in make
    cls = load(self._entry_point)
    File “/home/sam/.local/lib/python3.5/site-packages/gym/envs/”, line 14, in load
    result = entry_point.load(False)
    File “/usr/lib/python3/dist-packages/pkg_resources/”, line 2229, in load
    return self.resolve()
    File “/usr/lib/python3/dist-packages/pkg_resources/”, line 2235, in resolve
    module = __import__(self.module_name, fromlist=[‘__name__’], level=0)
    File “/home/sam/Project/duckietown/gym-duckietown-agent/gym_duckietown_agent/envs/”, line 1, in <module>
    from gym_duckietown_agent.envs.simplesimagent_env import SimpleSimAgentEnv
    File “/home/sam/Project/duckietown/gym-duckietown-agent/gym_duckietown_agent/envs/”, line 5, in <module>
    from duckietown_slimremote.pc.robot import RemoteRobot
    ImportError: No module named ‘duckietown_slimremote’

    Given that I tried pip3 install duckietown_slimremote and it did not work, anyone know what is the name of the package I should install?
    Btw, it works when I run it inside the docker container.



    For clarification, I am trying to do step 4 in I am running Ubuntu 16.


    In case you haven’t found it yet, you can build it from

    Then you can play with your PYTHONPATH or simply copy the folder duckietown_slimremote into the gym-duckietown-agent folder (not very clean but works)

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.