Front page Forums Technical Duckiebot Setup (connections, etc.) Setting up duckietown on a new computer

This topic contains 1 reply, has 2 voices, and was last updated by  duckietown_mum 1 month, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35853

    flybot
    Participant

    Hello,
    I have previously used duckietown and set up the duckiebot and everything. But now I am trying to set it up a new computer. I’m getting stuck on the step where it verifies my token. I already have a token, so should that work even with a new computer and how do I transfer that, or do I have to create a new account and get a new token?

    During setting up the new computer I ran “dts tok set”, which should open a command prompt, but instead I get the following:
    INFO:dts:duckietown-shell 4.0.12
    duckietown-shell works with Python 3.6 and later.
    Detected 2.7.15rc1 (default, Nov 12 2018, 14:31:15)
    [GCC 7.3.0].

    I checked and I am running Python 3.6.7.

    I’m not sure how to setup duckietown to work on this new computer.

    Thank you!

    • This topic was modified 1 month, 1 week ago by  flybot.
    #36701

    duckietown_mum
    Participant

    I also had this problem with my last laptop-setup. I fixed it by editing the file ~/.local/bin/dts.
    I changed the first line from #!/usr/bin/python to #!/usr/bin/python3.

    I reinstalled Ubuntu lately and I’m currently using dts 4.0.18 and there the line seems to be fixed.

    I hope this helps!

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Close Menu