0

What if no window appears when I run the dts calibration script?   Here is my log, and I am simultaneously streaming images in rviz.  No window appears, and I’m not sure what went wrong.

[email protected]:~
$ dts duckiebot calibrate_all cuckooface
INFO:dts:duckietown-shell 3.0.31
dts : Problems with a command?
:
: Report here: https://github.com/duckietown/duckietown-shell-commands/issues
:
: Troubleshooting:
:
: – If some commands update fail, delete ~/.dt-shell/commands
:
: – To reset the shell to “factory settings”, delete ~/.dt-shell
:
: (Note: you will have to re-configure.)
/home/stefie10/.local/lib/python2.7/site-packages/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.
warnings.warn(warning, RequestsDependencyWarning)
Duckietown Shell commands version 1.1.1
Running /bin/bash /home/stefie10/.dt-shell/commands/duckiebot/calibrate_all/calibrate_duckiebot.sh cuckooface 192.168.1.19
master18: Pulling from duckietown/rpi-duckiebot-calibration
Digest: sha256:8079c7bcb24587335ddde51862938d81a1f9372fda17d877c4f25a42ff19d06b
Status: Image is up to date for duckietown/rpi-duckiebot-calibration:master18
master18: Pulling from duckietown/rpi-duckiebot-base
Digest: sha256:559c511e4039f2d4cfa9217e9d034e1531bdb15361c608774c9669ded2dab0f1
Status: Image is up to date for duckietown/rpi-duckiebot-base:master18
access control disabled, clients can connect from any host
Setting ROS_IP to host IP, which is 192.168.1.20
Writing “192.168.1.19 cuckooface cuckooface.local” into /etc/hosts
Activating ROS with shell: /bin/bash
Set DUCKIETOWN_ROOT to: /home/software
Set PYTHONPATH to: /home/software/catkin_ws/src:/opt/ros/kinetic/lib/python2.7/dist-packages
Activating development environment…
…..
………
. .. ….
. .. ….
. ………….
.. .. … ..
. ……… …..
. . ……. ………
. . … …….
………. ……
. . …….. …..
. …. …..
…………….
………..
********************
Position the checkerboard pattern in front of the Duckiebot and press ENTER.

Asked question